Work in progress: 181,232 of 181,233 sites checked so far, more every week · updated 2 Nov 2026Missing a blog? Tell us

Top all-time · #4674

S

Stéphane Bortzmeyer

Personal blog · bortzmeyer.org · on HN as bortzmeyersystemsweb

Stéphane Bortzmeyer's personal blog at bortzmeyer.org covers systems and web. Since 2013, 17 different Hacker News readers have linked it 22 times, most often “Hijacking of public DNS servers in Turkey, through routing”. It is still writing: the last post was on 2026-10-31, and you can follow it by feed.

Visit the blog
22mentions?
17HN people?
2013–2024first – last linked?
Links on Hacker News per year · peak 6 in 2014

Too few sampled comments (9) to say how often HN recommends it.?

Why HN links it

HN readers link Stéphane Bortzmeyer's French-language blog for DNS and internet-standards posts, including DNS-over-HTTPS setup, a DNS routing hijack in Turkey, and an explanation of RFC 8240 debates.

Summarised by Claude from a sample of 9 HN comments that link here. Each comment is marked recommending, critical or neutral (citing without judging); how this works.

The author on HN?

bortzmeyer · 10 karma · member since 2013

http://www.bortzmeyer.org/

From their public HN profile, which links to this site.

Most-linked posts?

  1. Hijacking of public DNS servers in Turkey, through routing
    3 people · 3 mentions · first linked 2014-03-30
  2. Observations about the attack on WikiLeaks
    2 people · 3 mentions · first linked 2017-09-01
  3. Developing DNS-over-HTTPS clients and servers at the IETF101 hackathon
    2 people · 2 mentions · first linked 2018-03-23

What Hacker News says?

  1. hilbert- · 2020-02-25Recommends
    There is an interesting guide (in French) on best-practices to get DoH up and running with dnsdist ( https://dnsdist.org ) here: https://www.bortzmeyer.org/doh-mon-resolveur.html . You might also be interested in looking at https://dnsdist.org/guides/dns-over-https.html

    Comment linking /doh-mon-resolveur.html

    on “Mozilla’s DNS over HTTPs”
  2. Submitted Observations about the attack on WikiLeaks as a story · 20 points

    HN discussion
  3. This. Websites are supposed to distinguish internal and external links. It makes it way easier to now what kind of information we will be getting when clicking. My first thought is for a blog [1] which does it pretty well: (internal links are underlined. [1] http://www.bortzmeyer.org/ (fr) (I could not think of an English-speaking website with a similar differentiation right away) Edit: just look at Wikipedia https:…

    Comment linking /

    on “Complaint-Driven Development”
  4. Submitted Observations about the DNS attack on WikiLeaks as a story · 3 points

    HN discussion
  5. bigbugbag · 2014-05-30Recommends
    Turns out jblow's right. I banished OpenDNS because it was breaking basic DNS functionality to serve its ads (and is terrible privacy wise), this is the exact bad behaviour from ISP openDNS was supposed to help with. But don't take my word for it and read this 2009 post from Stephane Bortzmeyer working at AFNIC in R&D in DNS security[1]. As jblow said the whole "no more ads" post reads as PR spin, same goes for your…

    Comment linking /opendns-non-merci.html

    on “No more ads”
  6. Submitted Getting TAI time on a Debian machine as a story · 2 points

    HN discussion
  7. http://www.bortzmeyer.org/bgp-malaisie.html

    Comment linking /bgp-malaisie.html

    on “Hacking Team and a case of BGP hijacking”
  8. Submitted A dynamic experimental DNS server as a story · 2 points

    HN discussion
  9. karteum · 2023-09-05Recommends
    You might be interested in this (in French, but you may try with google translate or other alternatives :) https://www.bortzmeyer.org/8240.html It is a very interesting explanation of debates around https://www.rfc-editor.org/rfc/rfc8240.txt

    Comment linking /8240.html

    on “Ask HN: I’m an FCC Commissioner proposing regulation of IoT security updates”
  10. Submitted RFC 8467: Padding Policies for Extension Mechanisms for DNS (EDNS(0)) as a story · 2 points

    HN discussion
  11. Looks like this is actually being done through IGP: http://www.bortzmeyer.org/dns-routing-hijack-turkey.html

    Comment linking /dns-routing-hijack-turkey.html

    on “Google’s Public DNS intercepted in Turkey”
  12. Submitted RFC 8446: The Transport Layer Security (TLS) Protocol Version 1.3 as a story · 2 points

    HN discussion
  13. paulv · 2014-03-30Recommends
    Yes, but it isn't wizardry. Given the right kind of access, it's actually pretty easy. Take a look at http://www.bortzmeyer.org/dns-routing-hijack-turkey.html for more technical details.

    Comment linking /dns-routing-hijack-turkey.html

    on “Google’s Public DNS intercepted in Turkey”
  14. Submitted Developing DNS-over-HTTPS clients and servers (IETF hackathon) as a story · 2 points

    HN discussion
  15. End-to-end security of the channel isn't necessary. DNS is public. There are clues that DNS is broken in those situations that, as with SSL, ultimately your browser would have to present to you. Local validation is all you can count on. E.g. http://www.bortzmeyer.org/dns-swisscom.html Personally, I'm now twice as interested in relying on DNSSEC and running my own DNS resolution rather than relying on third-parties.…

    Comment linking /dns-swisscom.html

    on “DNSSEC has failed”
  16. Submitted Developing DNS-over-HTTPS clients and servers at the IETF101 hackathon as a story · 2 points

    HN discussion
  17. What makes you tell it looks like DNS poisoning? It if were DNS poisoning, some resolvers would have been poisoned but not all, while, here, everybody saw the attacker's IP address. http://www.bortzmeyer.org/observations-wikileaks.html

    Comment linking /observations-wikileaks.html

    on “WikiLeaks suffers a DNS poisoning attack; The Guardian claims they were “hacked””
  18. Submitted DNS Looking Glasses as a story · 2 points

    HN discussion
  19. No, nothing indicates it was a poisoning attack. Please check the facts. http://www.bortzmeyer.org/observations-wikileaks.html

    Comment linking /observations-wikileaks.html

    on “WikiLeaks suffers a DNS poisoning attack; The Guardian claims they were “hacked””
  20. Submitted RFC 8493: The BagIt File Packaging Format (V1.0) as a story · 1 points

    HN discussion
  21. https://www.bortzmeyer.org/8461.html

    Comment linking /8461.html

    on “SMTP MTA Strict Transport Security (MTA-STS)”
  22. Submitted Hijacking of public DNS servers in Turkey, through routing as a story · 1 points

    HN discussion

Search all of HN for bortzmeyer.org

Linked by the same people?